Main Content

Magnolia Community Forums: Development: content search not works at component level


  • jain-chetan68
    jain-chetan68
    Full name: chetan jain
    Posts: 13
    Last post: Jul 9, 2016 11:30:21 AM
    Registered on: Oct 8, 2015
    content search not works at component level
    #1 by jain-chetan68 on Jul 6, 2016 3:39:52 PM

    Hi,

    We have noticed that in our case, if we are searching any content then it's not find if it is in a component data. search is working well at page level, it is searching page content but not in area, component etc.

    we are using searchfn.searchPage();

  • cmeier
    cmeier
    Full name: Christoph Meier
    Posts: 210
    Last post: Jul 25, 2017 6:09:04 PM
    Re: content search not works at component level
    #2 by cmeier on Jul 7, 2016 5:21:20 PM

    Hello

    Please provide more details about:
    - What exactly you want to achieve / to search.
    - How you have tried to do it so far.

  • jain-chetan68
    jain-chetan68
    Full name: chetan jain
    Posts: 13
    Last post: Jul 9, 2016 11:30:21 AM
    Registered on: Oct 8, 2015
    Re: content search not works at component level
    #3 by jain-chetan68 on Jul 9, 2016 10:43:18 AM

    Actually what we are doing right now,

    search e.g word "internet" in search field, as magnolia does with searchfn function with searchPages & searchContent methods. and "internet" word is available in home page under "page/area/component" as magnolia says, it searches pages content under this hierarchy "page/area/component", then the same structure we are following but it didn't search home page content at all. then we got some where it was a kind of bug in 5.4.4 and it is resolved in 5.4.7 but also tried with 5.4.7 with demo website "travel" but facing same issue.

    I hope now you got my point.

    Tthanks.

You don't have the permission to post on this thread

Sign in

To login on this forum, you can use your Magnolia Forge, Support or Partner account, or, below, your Google, Yahoo! or OpenID account. If you have trouble logging in, or any other sort of issue, please let us know in the Meta forum, on the user-list, or simply by email at forum-admin at magnolia-cms dot com.

* Required

... or sign in with:

  • icon http://{your-openid-url}
  • icon
  • icon https://me.yahoo.com/