Main Content

Magnolia Community Forums: Development: Session attributes EMPTY


  • Mario-Rossi17
    Mario-Rossi17
    Full name: Mario Rossi
    Posts: 2
    Last post: Oct 11, 2016 11:28:10 AM
    Registered on: Oct 11, 2016
    Session attributes EMPTY
    #1 by Mario-Rossi17 on Oct 11, 2016 9:28:57 AM

    Hi,

    I'm trying to "extends" user registration using my custom components, I have added hidden input fields inside my form.
    But I have a problem during registration, in the RegistrationProcessor method "parameters" are empty, I have debug a lot and I found that when it try to get the form state using "session.getAttribute(FORM_STATE_ATTRIBUTE_PREFIX + formStateToken)" my session has no values, it's empty.
    Maybe I have to pass some specific params in my form ? Someone can help me ?

    Thank you

    MR

  • Mario-Rossi17
    Mario-Rossi17
    Full name: Mario Rossi
    Posts: 2
    Last post: Oct 11, 2016 11:28:10 AM
    Registered on: Oct 11, 2016
    Re: Session attributes EMPTY
    #2 by Mario-Rossi17 on Oct 11, 2016 11:28:10 AM

    CORRECTION

    The problem is before, when in FormEngine is called handleRequest(Node content) the obj "content" doesn't contains my input fields.

You don't have the permission to post on this thread

Sign in

To login on this forum, you can use your Magnolia Forge, Support or Partner account, or, below, your Google, Yahoo! or OpenID account. If you have trouble logging in, or any other sort of issue, please let us know in the Meta forum, on the user-list, or simply by email at forum-admin at magnolia-cms dot com.

* Required

... or sign in with:

  • icon http://{your-openid-url}
  • icon
  • icon https://me.yahoo.com/