Main Content

Magnolia Community Forums: Get help with Magnolia: Troubles with contentConnector


  • piotrkowy
    piotrkowy
    Full name: Piotr
    Posts: 1
    Last post: Jan 11, 2017 12:19:49 PM
    Registered on: Jan 11, 2017
    Troubles with contentConnector
    #1 by piotrkowy on Jan 11, 2017 12:19:49 PM

    Hey there,
    since yesterday I have been facing the following problem:

    I tried to create a new content app basing on this instruction:

    https://documentation.magnolia-cms.com/display/DOCS/My+first+content+app#0accd964f6644ca9832df0022ffbf7f8

    unfortunately, after creating the same catalog tree in my java project and starting the Tomcat server I still wasn't able to see the JCR node in config/modules/mymodule/products.

    I created a new section in 'edit' group, but after clicking it I am redirected to the catalog without any buttons available (edit, add product etc. despite adding them in products.yaml) and I get this error:

    2017-01-11 11:43:55,735 ERROR n.integration.contentconnector.JcrContentConnector: Failed to retrieve default id: products, returning null.
    javax.jcr.NoSuchWorkspaceException: products
    at info.magnolia.repository.DefaultRepositoryManager.getSession(DefaultRepositoryManager.java:300)
    at info.magnolia.context.DefaultRepositoryStrategy.internalGetSession(DefaultRepositoryStrategy.java:61)
    at info.magnolia.context.AbstractRepositoryStrategy.getSession(AbstractRepositoryStrategy.java:75)
    at info.magnolia.context.AbstractContext.getJCRSession(AbstractContext.java:132)
    at info.magnolia.context.MgnlContext.getJCRSession(MgnlContext.java:656)
    at info.magnolia.ui.vaadin.integration.jcr.JcrItemUtil.getItemId(JcrItemUtil.java:17
    ...

    It was ok, because the JCR node was not created.

    But then, I tried to add the JCR node with products parameters step by step by myself, and I kept getting this error.

    Do you guys have any idea what's the cause of this problem? Some dependencies or sth? Maybe I should add some handlers, classes to my project?

    I would add, that in magnolia-travels demo there is no catalog 'app' present in the whole project, and despite this content-apps are visible in author panel.

    I completely don't get this approach + it is not explained in magnolia's documentation.

    Thanks in advance for your reply.

  • cmeier
    cmeier
    Full name: Christoph Meier
    Posts: 195
    Last post: Apr 18, 2017 5:34:26 AM
    Re: Troubles with contentConnector
    #2 by cmeier on Jan 17, 2017 3:01:53 AM

    Hello Piotr

    Please provide some more infos what you have done exactly.

    Have you followed the "my first content app" tutorial precisely, or have you created your own new app trying to follow the tutorial?
    What this tutorial is covering only on the surface: the module descriptor and registration of a new workspace.

    Have you created a new module descriptor?
    How does it look like?
    And the same questions for the node-types.xml

    Please have a look at these 2 file at git - which belong to the documentation "app-tutorial" (described as "my first content app" on the doc page):

    (1) module descriptor:
    https://git.magnolia-cms.com/projects/DOCUMENTATION/repos/app-tutorial/browse/src/main/resources/META-INF/magnolia/magnolia-module-app-tutorial.xml

    (2) node-types:
    https://git.magnolia-cms.com/projects/DOCUMENTATION/repos/app-tutorial/browse/src/main/resources/mgnl-nodetypes/app-tutorial-nodetypes.xml

    The tutorial proposes to create a distinct node type for the app - which by the way is not always required. Instead you can just use one of the existing node types.
    However, if you rely on a deistinct node type, you have to define it in the node-types.xml.
    (See file 2 above)

    If you rely on a distinct workspace - which is also proposed by the tutorial - you have to register the new workspace and pointing to your node-types.xml (See file (1) above)

    I hope this helps,
    cheers,
    Christoph

You don't have the permission to post on this thread

Sign in

To login on this forum, you can use your Magnolia Forge, Support or Partner account, or, below, your Google, Yahoo! or OpenID account. If you have trouble logging in, or any other sort of issue, please let us know in the Meta forum, on the user-list, or simply by email at forum-admin at magnolia-cms dot com.

* Required

... or sign in with:

  • icon http://{your-openid-url}
  • icon
  • icon https://me.yahoo.com/