Main Content

Magnolia Community Forums: Get help with Magnolia: ModuleManagementException: No module definition was found.


  • mnicklisch
    mnicklisch
    Full name: Matthias Nicklisch
    Posts: 6
    Last post: Mar 9, 2017 11:37:39 AM
    Registered on: Feb 23, 2017
    ModuleManagementException: No module definition was found.
    #1 by mnicklisch on Feb 24, 2017 5:02:12 PM

    Hello guys,

    in the last few days I started to look into Magnolia. We want to develop a module.

    I followed this tutorial: https://academy.magnolia-cms.com/display/MA/Hello+World+-+IDE

    I've done exactly the same, with the exception that I used this command here, the one in the video didn't work:

    mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -DarchetypeCatalog=https://nexus.magnolia-cms.com/content/groups/public/


    Also I used Magnolia version 5.5

    I have set up everything in the IDE (Eclipse Neon.2) and when I start the server I get the error message:

    ModuleManagementException: No module definition was found.

    I have found some articles of people who already had this error.

    This one here:
    https://forums.magnolia-cms.com/forum/thread.html?threadId=022f35f7-cde9-49fa-a1f5-9d44b8da8ed3&page=1

    But that was exactly what I've done. I repeated everything with a new project and still get the same error.

    And this one here:
    http://user-list.magnolia.narkive.com/WqqXsAD8/magnolia-testing-modulemanagementexception

    I was looking for the Jira ticket, but couldn't extract any useful information here:
    https://jira.magnolia-cms.com/browse/MAGNOLIA-2593

    Also the code mentioned in the thread above didn't help, since I have no idea where to put it^^

    In another thread someone had the same error, but he didn't respond to any questions following (can't find it right now)

    I am using a Tomcat 8.24 and Java 8.

    I would really appreciate some help here =)

    Thanks in advance.

    Matthias

  • mnicklisch
    mnicklisch
    Full name: Matthias Nicklisch
    Posts: 6
    Last post: Mar 9, 2017 11:37:39 AM
    Registered on: Feb 23, 2017
    Re: ModuleManagementException: No module definition was found.
    #2 by mnicklisch on Feb 24, 2017 5:27:35 PM

    And yes, I have the same behaviour that when I build a war file and deploy it to my server and start it from the console (without eclipse) the server starts.

  • mnicklisch
    mnicklisch
    Full name: Matthias Nicklisch
    Posts: 6
    Last post: Mar 9, 2017 11:37:39 AM
    Registered on: Feb 23, 2017
    Re: ModuleManagementException: No module definition was found.
    #3 by mnicklisch on Feb 27, 2017 11:12:20 AM

    I have found the error:
    When you change your server config, like shown in the video tutorial, don't set the option "Serve modules without publishing"
    When this option is activated, the error described above will occur. If it is not set, everything works fine...

You don't have the permission to post on this thread

Sign in

To login on this forum, you can use your Magnolia Forge, Support or Partner account, or, below, your Google, Yahoo! or OpenID account. If you have trouble logging in, or any other sort of issue, please let us know in the Meta forum, on the user-list, or simply by email at forum-admin at magnolia-cms dot com.

* Required

... or sign in with:

  • icon http://{your-openid-url}
  • icon
  • icon https://me.yahoo.com/