Main Content

Magnolia Community Forums: Get help with Magnolia: installing modules does not work


  • tbrzyk
    tbrzyk
    Full name: Tom Brzyk
    Posts: 1
    Last post: Mar 2, 2017 1:53:05 PM
    Registered on: Feb 15, 2017
    installing modules does not work
    #1 by tbrzyk on Mar 2, 2017 1:53:05 PM

    I cannot install the DAM modules on magnolia 5.4.7. I tried versions 2.1.1 to 2.1.7. The error that I get is on the DAM-app module with the error:

    Caused by: java.lang.IllegalArgumentException: java.util.zip.ZipException: invalid LOC header (bad signature)
    at org.apache.catalina.webresources.AbstractSingleArchiveResourceSet.initInternal(AbstractSingleArchiveResourceSet.java:113)
    at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:107)
    ... 12 more
    Caused by: java.util.zip.ZipException: invalid LOC header (bad signature)
    at java.util.zip.ZipFile.read(Native Method)
    at java.util.zip.ZipFile.access$1400(Unknown Source)
    at java.util.zip.ZipFile$ZipFileInputStream.read(Unknown Source)
    at java.util.zip.ZipFile$ZipFileInflaterInputStream.fill(Unknown Source)
    at java.util.zip.InflaterInputStream.read(Unknown Source)
    at sun.misc.IOUtils.readFully(Unknown Source)
    at java.util.jar.JarFile.getBytes(Unknown Source)
    at java.util.jar.JarFile.getManifestFromReference(Unknown Source)
    at java.util.jar.JarFile.getManifest(Unknown Source)
    at org.apache.catalina.webresources.AbstractSingleArchiveResourceSet.initInternal(AbstractSingleArchiveResourceSet.java:111)
    ... 13 more

    The empty web-app works fine and I can install my own maven modules. Could anybody help me please? I have the same error while I install the observation module.

  • cmeier
    cmeier
    Full name: Christoph Meier
    Posts: 195
    Last post: Apr 18, 2017 5:34:26 AM
    Re: installing modules does not work
    #2 by cmeier on Mar 6, 2017 8:26:55 AM

    Hi Tom

    Please provide a Maven dependency tree of your custom webapp.
    Use mvn dependency:tree to create the tree.

    And some more information about your environment:
    - OS
    - Java version
    - application server (vendor and version)

    By the way.
    On preconfigured Magnolia 5.4.7 bundles, DAM version 2.1.5 is used.

    cheers,
    Christoph

  • breun
    breun
    Full name: Nils Breunese
    Posts: 418
    Last post: Mar 6, 2017 10:16:19 AM
    Registered on: Sep 16, 2010
    Re: installing modules does not work
    #3 by breun on Mar 6, 2017 10:16:19 AM

    From "java.util.zip.ZipException: invalid LOC header (bad signature)" line I get the feeling you might have a corrupted JAR in your local repository. You could try (re)moving suspected artifacts from your ~/.m2/repository and having Maven download them again.

You don't have the permission to post on this thread

Sign in

To login on this forum, you can use your Magnolia Forge, Support or Partner account, or, below, your Google, Yahoo! or OpenID account. If you have trouble logging in, or any other sort of issue, please let us know in the Meta forum, on the user-list, or simply by email at forum-admin at magnolia-cms dot com.

* Required

... or sign in with:

  • icon http://{your-openid-url}
  • icon
  • icon https://me.yahoo.com/