Main Content

Magnolia Community Forums: Get help with Magnolia: Which version of Standard Templating Kit to use with Magnolia 4.5.2?


  • lorenooliveira
    lorenooliveira
    Full name: Loreno Oliveira
    Posts: 1
    Last post: Apr 10, 2012 9:57:20 PM
    Registered on: Apr 10, 2012
    Which version of Standard Templating Kit to use with Magnolia 4.5.2?
    #1 by lorenooliveira on Apr 10, 2012 9:57:20 PM

    I'm quite new to magnolia, actually I'm trying to install it yet.

    Following the step by step at http://documentation.magnolia-cms.com/administration/installation/ce/ce-linux.html I found that the STK doesn't mix with magnolia 4.5.2. I tried both 2.0.1 and 2.0.2 versions of STK, but in both cases I get the following problem when I restart magnolia:

    info.magnolia.module.model.reader.ModuleDependencyException: Module Magnolia Commenting Module (version 1.2.2) is dependent on core version 4.5.2/*, but Magnolia Core Module (version 4.5.1) is currently installed.

    Any advice on that?

  • ahietala
    ahietala
    Full name: Antti Hietala
    Posts: 272
    Last post: Jul 23, 2014 8:24:41 AM
    Re: Which version of Standard Templating Kit to use with Magnolia 4.5.2?
    #2 by ahietala on Apr 11, 2012 1:46:53 PM

    Hi Loreno,

    There are two issues, neither of which you could possibly anticipate:

    1. Starting with Magnolia CMS 4.5, the Standard Templating Kit is included in the Magnolia-Tomcat bundle. This means that you don't need to download the STK bundle separately. The installation document was not up-to-date but it is now.

    2. The STK bundle includes a number of JAR files such as Magnolia core which should not be there. This caused the version conflict in your error message. The issue is reported as MGNLSTK-941 and will be fixed.

    To move forward, do a fresh install of the 4.5.2 Magnolia-Tomcat bundle. STK will be included, no additional download necessary. And thanks for posting the error!

    http://documentation.magnolia-cms.com/administration/installation/ce/ce-linux.html
    http://jira.magnolia-cms.com/browse/MGNLSTK-941

  • picturedesk80
    picturedesk80
    Full name: Mario Ammann
    Posts: 2
    Last post: May 19, 2014 6:03:11 PM
    Registered on: May 14, 2013
    Re: Which version of Standard Templating Kit to use with Magnolia 4.5.2?
    #3 by picturedesk80 on May 14, 2013 2:39:44 PM

    Hi

    For an project we have to use an older Magnolia version 4.4.6 and unfortunately STK is there not included. If I download all the required modules (dms & categorization & STK) and put them into the WEB-INF folder. After restart I always get a 404 error. I'm using the tomcat-budle.

    Those modules i'll install:
    http://store.magnolia-cms.com/module-list/magnolia/standard-templating-kit-migration.html
    http://store.magnolia-cms.com/module-list/magnolia/categorization.html
    http://store.magnolia-cms.com/module-list/magnolia/dms.html

    May you have a solution or an idea to solve this problem.

    Thank you in advanced.

You don't have the permission to post on this thread

Sign in

To login on this forum, you can use your Magnolia Forge, Support or Partner account, or, below, your Google, Yahoo! or OpenID account. If you have trouble logging in, or any other sort of issue, please let us know in the Meta forum, on the user-list, or simply by email at forum-admin at magnolia-cms dot com.

* Required

... or sign in with:

  • icon http://{your-openid-url}
  • icon https://www.google.com/accounts/o8/id
  • icon https://me.yahoo.com/